The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

SDB:Firefox MP4/H.264 Video Support

Перейти к: навигация, поиск
  1. REDIRECT Если Firefox не может воспроизвести некоторые HTML5 видеозаписи, то эта статья должна помочь в разрешении данной проблемы.

Краткое изложение решения

  1. Добавьте репозиторий Packman Essentials (особенно, если используется Leap) или VLC в котором содержится полнофункциональная библиотека ffmpeg/libav.
  2. Установите пакеты libavcodec56, libavcodec57, libavformat56, libavformat57, libavdevice56, libavdevice57 из репозитория добавленного на предыдущем шаге. Другие пакеты libav будут установлены автоматически как рекомендуемые.
  3. Если в системе уже установлены пакеты libav из основного репозитория openSUSE, то их следует переключить на Packman или VLC. С помощью YaST это можно сделать следующим образом:
    1. Найдите и выберете нужный пакет.
    2. Откройте вкладку "Версия" ниже списка пакетов.
    3. Выберите последнюю версию доступную в Packman/VLC.
    4. В случае появления каких либо проблем разрешения зависимостей просто выберите "Сменить поставщика openSUSE --> Packman / VLC".
    5. Нажмите кнопку "Применить" и дождитесь установки пакетов.
  4. Перезапустите Firefox.
  5. Возможно, лучше полностью перезагрузить компьютер. По крайней мере, завершить текущую сессию.
  6. Примечание: с помощью командной строки можно добиться того же результата: убедитесь, что в системе добавлен репозиторий Packman, а затем просто выполните следующую команду от имени root: "zypper up --allow-vendor-change"

Дополнительные сведения

Исторически так сложилось, что видеоформат MP4/H.264 стал широко используемым в Интернете. Многие веб-сайты предоставляют видео ролики для видеопотока HTML5 только формате MP4. Поэтому, если ваш веб-браузер не поддерживает кодек H.264, эти видео будет нельзя загрузить или воспроизвести.

Для решения проблем с патентными ограничения ни Firefox, ни openSUSE не предоставляют кодек H264. Вот почему новая установка openSUSE не может воспроизводить видео на веб-страницах. К счастью, в репозитория Packman и VLC есть полные версии этих пакетов. После установки библиотек libav Firefox обнаружит их и будет использовать для декодирования видео MP4/H.264.

openSUSE предоставляет пакеты ffmpeg/libav (включая libavcodec56), но они не содержат полной функциональности. Все кодеки связанные с патентными ограничениями были удалены, поэтому с их помощью невозможно воспроизвести видео в формате MP4/H.264. По этому эти пакеты необходимо установить из Packman/VLC.

Для проверки наличия поддержки воспроизведения H.264 видео в Firefox воспользуйтесь следующими ресурсами:

Несмотря на то, что вместе с Firefox поставляется OpenH264 плагин (от Cisco), он НЕ используется для декодирования HTML5 видео.

VLC плагин для Firefox не имеет никакого отношения к HTML5 видео. Он только предоставляет возможность встраивания проигрывателя VLC в веб-страницы.

Неофициальный Firefox плагин для декодировщиков xine может работать некорректно. В случае выявления проблем следует удалить этот плагин и использовать ffmpeg/libav вместо него.